[pmwiki-users] Page still blank in edit mode

Dawa bigdawa at gmail.com
Mon Aug 20 04:36:27 CDT 2007

Hi Petko,

Ok and thanks for all, I'll let you know about the new install very soon.

And I don't understand for the infinite loop, the site is working fine
for me, no problem ??

2007/8/20, Petko Yotov <5ko at free.fr>:
> On Monday 20 August 2007, Dawa wrote:
> > Hi Petko
> >
> > 2007/8/18, Petko Yotov <5ko at free.fr>:
> > > Did you also hag upgraded your PHP installation? In that case, see this
> > > message and thread at the mailing list:
> > >   http://article.gmane.org/gmane.comp.web.wiki.pmwiki.user/40297
> >
> > My site works perfectly until my webhost have upgraded his servers but
> > not to php 5.
> >
> > > Otherwise, maybe you can post the contents of your farmconfig.php and
> > > config.php? What recipes and what settings have you installed?
> > >
> > > Also, show us your site, and set in config.php the line:
> > >
> > >    $EnableDiag = 1;
> > >
> > > This will enable PmWiki's diagnostic tools and we can have a look and try
> > > to locate the problem. An edit permission is also a good idea.
> >
> > Ok I've setup EnableDiag so you can use the action=diag and action=phpinfo
> Hi. I looked at the site and could not find the problem. Such blank page
> happens, as Peter K.H. Gragert said in a parallel message, when there is a
> call to an unrecognized function, preceded by "@" (which means "suppress any
> error messages by this function"). This may happen if a script expects a
> native php function to be available, and it isn't (php compiled without, or
> function disabled by safe mode), or a user written function that should be
> there but isn't (file not included?). I don't know for sure.
> What I can suggest is to install a new, clean, independent pmwiki in another
> directory of this site, and see if editing works,
> * without passwords and
> * with passwords (set the standard page password by calling Page?action=attr).
> Don't install AuthUser or UserAuth yet, nor any other recipes.
> 1. It may be a session problem (pmwiki tries to write session files in a
> write-protected or non existant directory) but in that case it should issue a
> warning message.
> 2. If it still doesn't work, if you cannot edit, the problem is with PmWiki
> and I hope that Patrick could look into this one.
> 3. If it works, if you can edit pages without passwords, and also with
> passwords, then the problem is in one of the recipes that you installed on
> the main site. You should:
>    * Install the same skin, test if editing works (if yes, skin is OK).
>    * Install one recipe, test if editing works (if yes, this recipe is OK).
>    * Install another recipe, test, etc.
> When you find the recipe with which the editing doesn't work and you get a
> blank page, tell us, and/or try to contact the maintainer of the recipe.
> Thanks,
> Petko
> P.S. I was able to see the site for a while, but now it enters an infinite
> redirect loop. I hope it's temporary.


More information about the pmwiki-users mailing list