[pmwiki-users] PHP Version

Petko Yotov 5ko at 5ko.fr
Mon Apr 11 00:31:04 CDT 2016

PHP 5.4 requires at least PmWiki 2.2.42, but all your existing recipes 
and skins should work fine, that is, it shouldn't be too difficult to 
upgrade. Nevertheless read the "Upgrades" page:


5.5 <= PHP < 7 requires PmWiki 2.2.58 or newer, and many recipes need to 
be updated - most often the markup definitions. Some maintainers have 
updated most of their recipes, but there are recipes that have not been 
updated for PHP 5.5 yet.

PHP >= 7 requires PmWiki 2.2.86, to be released this month (available 
now in Subversion). It will require the new-style (post PHP 5.5) markup 
definitions for recipes.


Change log     :  http://www.pmwiki.org/wiki/PmWiki/ChangeLog
Release notes  :  http://www.pmwiki.org/wiki/PmWiki/ReleaseNotes
If you upgrade :  http://www.pmwiki.org/wiki/PmWiki/Upgrades

On 2016-04-08 17:17, Kevin Hayes wrote:
> One of my  servers was recently upgraded to PHP 5.5, with the resulting
> preg_replace errors. I can troubleshoot it and fix it, but will want to
> relocate temporarily to a server running an earlier version.
> Will 5.4 work? Any other suggestions?

More information about the pmwiki-users mailing list