[Pmwiki-users] New Install - Broken Wiki Word Links

Jason Newquist jason
Sun Dec 7 08:22:22 CST 2003

New by-the-book install on a Yellow Dog Linux box running Apache
2. The various hardcoded links like "Search" and whatnot are all
good!  "AcceptPathInfo on" placed in httpd.conf, Apache restarted,
no problems there.

But all the default WikiWord links have question marks.  But
when I click them to see if it's a 404 or what, I am presented with
the content of that page for editing.  So the editing routine has
the page, but the page display and link builder doesn't.

Thinking that this problem might be confined to the distribution
pages only and not to user-created pages, I experimented further.

I created a new wiki link on the front page for FooBar, then I
created content for FooBar.  I refreshed the front page, and it's
still there... not "_FooBar_" as it should be, but still "FooBar?".
I clicked on the ? again, and there's my content, presented for

I suspected browser cache, so I tried other browsers.  Same result.
I reinstalled, and gave both the default and the user .d directories
generous permissions (777), and confirmed that everything was owned
by the Apache user and group.

Any ideas what I might be missing?

Jason Newquist
San Francisco Bay Area

More information about the pmwiki-users mailing list