[pmwiki-users] XMLRPC Testers Please

Crisses crisses at kinhost.org
Sat Feb 15 20:05:57 CST 2014

Thank you, Eric,

I saw that someone posted 2 Android posts on the wiki when I looked at the AllRecentChanges but the group name is '1' which means that the application passed information incorrectly.  It's supposed to pass the group name back when it posts, and I use the group name to form the PmWiki page.  If whomever did that tries again, try a title with the group name in it: i.e. Blog.TestAndroid instead of just TestAndroid. That may correct that issue.

Just fixed the plug-in so it should save the page author's name -- otherwise I'd have known who tried to post (oops!).

Chris K. also tried a couple clients on Linux today... He did manage to post using Blogilo -- but the newlines were stripped out on the way back to the wiki :(  Unfortunately that renders it mostly useless.  

I straightened out the instructions to make the settings as clear as possible (every client handles credentials differently -- very confusing!):  http://www.pmwiki.org/wiki/Cookbook/XMLRPC-Talk  Only MetaWebLog API has been implemented, and you have to use the API link (there is no auto-discover, no idea how that works).

I'm only creating pass-through code for PmWiki to talk to a phpxmlrpc plug-in.  I'll keep trying.  To help with testing clients without consoles, I've been trying to figure out how to get the original client XML requests to pass through to a log file...  With most apps I'm testing blind.  MarsEdit I've gotten quite far with because there's a console in the app and I can see exactly what's being passed back & forth -- between that and tons of debug messages to the php/apache logs, I'm making progress.  Some progress.

Unfortunately the phpxmlrpc mailing list is quiet and hasn't been particularly helpful regarding the newline problems I'm having.


On Feb 15, 2014, at 6:31 PM, Eric Forgeot wrote:

> Good idea.
> On android unfortunately I couldn't get any app which worked with it.
> - Androdot (https://play.google.com/store/apps/details?id=com.androdot) said the website didn't respond (but this app seems quite buggy)
> - Typo3 (https://play.google.com/store/apps/details?id=de.hsregensburg.activities) said: "unknown method fehlercode:1"
> - Wordpress (https://play.google.com/store/apps/details?id=org.wordpress.android) is a very good app, but it can't connect. I'm not sure it's using xmlrpc either.
> - there is a xmlrpc client but it's not free and I'm not sure it's supposed to be used for posting things : https://play.google.com/store/apps/details?id=com.counterbolt.xmlrpcclient
> On Linux I tried blogilo, with MetaWebBlog or Wordpress API, but neither worked. When trying autoconfigure it said:
> The program can not detect the API of your blog but found a XMLRPC interface and will try to use it.
> The MovableType API is assumed from now on, please choose a different API if you know that the server recognizes.
> Then it told me unknown xml tag
> Gnome-blog could connect and list the existing Groups (Blog, Pmwiki etc), but I couldn't post.
> Drivel, another blog client for linux (gnome), didn't propose relevant protocols (only movable type, blogger etc, and none worked)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.pmichaud.com/pipermail/pmwiki-users/attachments/20140215/f4790207/attachment.html>

More information about the pmwiki-users mailing list