[pmwiki-users] pagelist template brainstorming

Skrol29 skrol29 at freesurf.fr
Mon Feb 19 10:37:16 CST 2007


I don't like the (:first:)(:each:)(:last:).
It will be so unwelcome when pmWiki will support loops for other purpose.
And when the PageList will support other features, it may be a generic
command name already reserved.
Remember how strange can be the names of PHP functions: reset() next()
end(). They are for arrays, but now all new array function is now prefixed
by "array_".

I think (:pagelist_first:) or (:pagelist-first:) looks longer that (:first:)
but it should not be a problem since it is not used so often over a pmWiki

I think (:pagelist_first:) ... is better than (:pagelist-first:).
Because "_" is never ambiguous, while "-" can looks like an operator or a
prefix for a parameter.

Does it make sens do have a syntax like this:
(:pagelist ope=first:) ?
Is it more consistence regarding to (:pagelist:) ?

I hope my comments can be useful,

More information about the pmwiki-users mailing list