[pmwiki-users] Documentation feedback + install question

John Hupp freedos at prpcompany.com
Fri Mar 31 18:06:50 CST 2006

Hello, all.  This is my first attempt with the successor to the FAQ system.  Kindly indulge me.

I just downloaded 0.9 SR2 and am trying this out on an old 486 computer that does not support a bootable CD. I was trying to use the prescribed installation boot disk created with fdos1440.img and WinImage.

As my first choice, I wanted to use Smart Boot Manager: The readme at http://fdos.org/ripcord/beta9sr2/readme.txt documents boot menus for the installation boot disk, and it describes a choice for a Smart Boot Manager which supports booting from CD even for many systems that do not natively support that.  But I found that Smart Boot Manager was not offered in the menus on the current installation boot disk.

As my second choice, I wanted to boot to the installation boot disk, selecting the most capable configuration my hardware supported (HIMEM + ... + CD-ROM), then run the installation/setup program from the CD-ROM.  But the Readme (above) does not say what EXE to run on the CD.  It merely says:
Once the active primary partition actually contains a filesystem, be it already present or just created through the FORMAT program, it will allow you to install FreeDOS using the installation program.  The installation program is intuitive to use ...

Poking around some on the CD, I thought that \freedos\setup\batch\AUTORUN.BAT might be the right file to run.  Later I settled on H:\freedos\setup\install\INSTALL.EXE, but without complete conviction.  An explicit statement in the Readme would be helpful.

Then there was the choice of installation mode: GUI or Text and the flavors of each.  I initially chose GUI 4-bit color.  But that generated error messages and terminated the installation.  Errors:
An unhandled exception occurred at 0x00048B72
Access violation
An unhandled exception occurred at 0x0005B36A
Access violation

So I made another attempt with Text mode installation.  The problem I ran into here was setting the Install-From location (where are the source files?).  After failing with several path entries, I finally seemed to succeed with <drive>:\freedos\packages\binbase.  Again, an explicit statement in the Readme would be helpful.

But then I found that the installation had not installed the kernel, so it seems that I still got something wrong.  Here is my only clue: When I tried to fix this and install the kernel by running SYS from FDOS\BIN and using FDOS\BIN as the source, I discovered that COMMAND.COM was not found there.  Nor was it already in the root directory.

Comments?  Anyone see my mistake(s)?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/pmwiki-users/attachments/20060331/6aa40a67/attachment.html 

More information about the pmwiki-users mailing list