[pmwiki-users] want opinions on a new cookbook recipe format

Dominique Faure dominique.faure at gmail.com
Tue Mar 7 10:45:34 CST 2006

On 3/7/06, Patrick R. Michaud <pmichaud at pobox.com> wrote:
> On Tue, Mar 07, 2006 at 08:42:53AM -0600, Patrick R. Michaud wrote:
> > Perhaps instead of "Version:" or "Recipe-version:" we should just use
> > "Date:" or "Updated:"?
> Actually, here's another big reason to be careful about "Version:" --
> {$Version} is already taken as a page variable,  and there's already
> a 'version' attribute in page files.
> So, we'd need a different page variable to represent the version
> of a recipe, and {$RecipeVersion} seems like a nice way to go.
> Of course, this means we should probably use {$RecipeSummary},
> {$RecipeVotes}, etc., which means we could leave the markup lines
> as "Summary:", "Version:", etc. and simply have them saved as
> "recipesummary", "recipeversion", etc. attributes and available
> as {$RecipeSummary}, {$RecipeVersion} variables.
> It might be nice to have a generic form for saved page properties,
> though, instead of tagging it with a specific name like "Recipe".
> Maybe {$PropVersion}, {$PropSummary}.  Or maybe another
> character besides just the '$', as in {$.Version} or {%Version}
> or something like that.  :-|

{$$Version} ?

with maybe an optional page name before the two $ ?


More information about the pmwiki-users mailing list