[pmwiki-users] Cannot authenticate via HTTP for editing/setting attributes

Alexandre Courbot gnurou at gmail.com
Fri Mar 3 08:17:29 CST 2006

Hello everyone,

This problem is so weird that I've decided to ask if someone here
would have a clue...

I'm setting a pmwiki site on a server I don't control. Therefore I
don't have much information about its configuration. Basic
installation worked just fine. After playing a little bit with it, I
wanted to set site-wide passwords for edit and attr actions.

The first problem was that pmwiki asked me my edit password way too
often. It asked for it when I click 'edit', but never seems to
remember it. Which results in having to enter the password again and
again not only when editing multiple pages, but also when clicking
'save' or 'preview'. I suppose there is not much that can be done
here, since it probably comes from Apache configuration.

To workaround this, I've included the scripts/httpauth.php file to
enable HTTP-based authentication. This is where things turned really
weird. If I edit a page, the access is invariably denied no matter the
password I enter (edit and admin passwords both didn't work). If I set
a site-wide read password, access is granted upon password entry and I
can read pages as expected. If I try to change the attributes of a
page, I can access the attributes setting page after entering the
right password. But if I try to submit, I'm asked for the password
again and am always rejected. Note that if I disable passwords, I can
edit and change attributes on pages without any problem.

I've tried with fresh installations of the latest 2.0 and 2.1. I'm
really confused here - if someone has a clue about what is going on,
I'd be most grateful.


More information about the pmwiki-users mailing list