[pmwiki-users] Can't access wikilib.d/ from wiki field

Scott Connard connard at dsg-inc.com
Thu Jun 1 10:24:29 CDT 2006


2.1.7 did NOT fix this problem.  It stops the looping, but still  
doesn't allow me to access the farm's wikilib.d files from a wiki   
field.  When trying to get to PmWiki/TextFormattingRules from a field  
wiki, I now get the error message:
?invalid page name

We are sorry for any inconvenience.

action=diag reports:
     [FarmD] => /Users/scott/Sites/pmwiki
     [WikiLibDirs] => Array
             [0] => pagestore Object
                     [dirfmt] => wiki.d/{$FullName}
                     [iswrite] => 0

             [1] => pagestore Object
                     [dirfmt] => $FarmD/wikilib.d/{$FullName}
                     [iswrite] => 0


And /Users/scott/Sites/pmwiki/wikilib.d/PmWiki.TextFormattingRules  
exists and can be accessed just fine from my host farm wiki.

Scott Connard.

On May 23, 2006, at 6:51 PM, Patrick R. Michaud wrote:

> On Tue, May 23, 2006 at 06:44:08PM -0400, Scott Connard wrote:
>> Patrick,
>> I wrote in about this problem once before and thought I had the
>> answer to it, but I didn't.  Now I have more of an answer, but I DO
>> think you have a bug.
>> I have a simple farm set up.  When I am in the host wiki I can access
>> the PmWiki documentation in wikilib.d/ just fine.  However, when I am
>> in a field wiki, I cannot get to the PmWiki documentation.  All other
>> aspects of the farm are working fine so I think I have all of my
>> variables, directories and permissions set correctly.
>> The Apache log shows about 16 redirects (all for my original
>> pagename) occurring when I go after one of the PmWiki documentation
>> pages.  I investigated pmwiki.php (although I do not code php) and
>> noticed redirect processing in ResolvePageName() along with some code
>> for an undocumented variable $EnableFixedUrlRedirect.  I discoverd
>> that if I set $EnableFixedUrlRedirect = 0; in my farmconfig.php,
>> everything works as expected.
>> Now I can live with that kludge fix, but it seems to me that you've
>> got a problem and some odd extra code.
>> I am running 2.1.5.
> 2.1.7 (released tonight/tomorrow) will change the handling of
> redirects slightly, but you still shouldn't have seen this
> particular behavior.  Is there a url that I could look at so
> I could see it happening myself?  I suspect an Apache configuration
> issue somewhere, but would like to make sure before I issue the next
> release.
> Thanks!
> Pm

More information about the pmwiki-users mailing list