jo at durchholz.org
Fri Jan 27 10:31:17 CST 2006
Patrick R. Michaud schrieb:
> Do you have any suggestions how we could better indicate where
> substitutions should take place...? Christian Ridderström suggests
> $DefaultPasswords['edit'] = crypt('<edit_password>');
> my only concern is that people will start to assume that the angle
> brackets are part of the syntax.
I tend to distinguish such stuff using markup. I.e. I'd write
$DefaultPasswords['edit'] = crypt('%subst%edit_password%%');
in wiki markup and define the subst style as, say, italic. (My initial
idea was to use italics directly, but that obviously doesn't work:
$DefaultPasswords['edit'] = crypt('''edit_password''');
Having a CSS style probably would be a better idea anyway.)
Oh, and somebody please give "subst" a better name.
More information about the pmwiki-users