[pmwiki-users] save problem

Michael.R.Doughty at frb.gov Michael.R.Doughty at frb.gov
Thu Sep 15 08:25:16 CDT 2005

pmwiki-users-bounces at pmichaud.com wrote on 09/15/2005 09:08:12 AM:
> Suggestion: Assuming you have pmwiki-2.0.5.tgz (I still use Beta55 and 
> Beta54) and have never used pmwiki before:
> If you don't need to save it
> 1) COMPLETELY wipe the pmWiki directory from the hard drive.
> 2) from the directory where the tgz file is located
> a) Enter "umask 002"
> b) |Enter "tar zxvf pmwiki|-2.0.5.tgz"|
> 3)Rename the ||pmwiki|-2.0.5 directory to "pmwiki" or "wiki"
> 4) Change to the "pmwiki" or "wiki" directory and enter "mkdir wiki.d"
> 5) Enter "chmod 777 wiki.d"
> 6) With no other changes, accesss the 
> wiki."internal_http_address/pmwiki/pmwiki.php" and attempt to Editand 
> the Main.HomePage.

Did all that.  Several times in fact, just to verify I hadn't messed it 

Is there a way I can get the program to tell me where things are falling 

I tried monkeying around with the pmwiki.php file, adding echos to the 
of function to try and trace the program through and see where it is 
failing, but
that didn't really get me anywhere.  It would be nice to know if it is 
failing somewhere along the way.

Being clueless, I hate to try giving diagnoses, but is it significant that 
the only
file ever created in the wiki.d directory is the .flock file?  From my 
quick scan
of the code (caveat:  I don't know PHP) it looks as though it should be 
copying the
page I am trying to edit to that directory when I first go to the Edit 

Not sure if I mentioned it before, but I am pretty sure it is not 
permissioning, as
I have tried both 'chmod -R 2777 pmwiki/' and 'chmod -R 777 pmwiki/ && 
chmod 2777 pmwiki/'
at step five above.  (I think I have installed from scratch about six or 
times now.)


More information about the pmwiki-users mailing list