[pmwiki-users] Change to Cookbook
pmwiki at solidgone.com
Sun Dec 11 12:38:47 CST 2005
Page updated with new script.
Patrick R. Michaud wrote:
> On Sat, Dec 10, 2005 at 01:45:07PM -0500, DaveG wrote:
>>Patrick R. Michaud wrote:
>>>I also think that we should use "value=" instead of "field=" for
>>>the default text, to be consistent with the parameter names used
>>>for other forms.
>>Sounds reasonable, although it sounds a little permenant to non-HTML
>>coders. How about "defaultvalue"? I don't feel too strongly either way.
> Just as a general philosophical position, I think that for markups
> dealing with form-level elements we can assume we aren't really
> targeting non-HTML coders. Staying with HTML attribute names
> also means that for those who have some familiarity with HTML
> (or those who may eventually become familiar with HTML) won't have
> to perform an internal mapping of "value" in HTML means "defaultvalue"
> in PmWiki.
>>I struggled with this (and naming the other variables too). I thought of
>>"buttonpos" but didn't like the abbreviation, and the full version does
>>seem a little long. "buttonside" sounds odd, but at this point I can't
>>come up with better. Maybe "buttonposition" is the way to go after all?
> After thinking about it, I'd go with just "button=right".
More information about the pmwiki-users