[pmwiki-users] Change to Cookbook
pmwiki at solidgone.com
Sat Dec 10 12:45:07 CST 2005
Patrick R. Michaud wrote:
> On Mon, Dec 05, 2005 at 09:42:34AM +0000, Hans wrote:
>>To bring this script in line with the original I suggest
>>to change "button" to "label" for the button label text.
> I also think that we should use "value=" instead of "field=" for
> the default text, to be consistent with the parameter names used
> for other forms.
Sounds reasonable, although it sounds a little permenant to non-HTML
coders. How about "defaultvalue"? I don't feel too strongly either way.
>>I also suggest to change "position" to "button", so one can write
>>"button=right" for a right sided button instead of "position=right", which
>>is a bit ambiguous, since it is not clear what it refers to, button or
>>box? "buttonposition" would be good, but it is so long.
> Maybe "buttonside"?
I struggled with this (and naming the other variables too). I thought of
"buttonpos" but didn't like the abbreviation, and the full version does
seem a little long. "buttonside" sounds odd, but at this point I can't
come up with better. Maybe "buttonposition" is the way to go after all?
More information about the pmwiki-users